Results for query "ERROR: Error installing sass: The last version of ffi (< 2, >= 0.5.0) to support your Ruby & RubyGems was 1.9.18. Try installing it with"

unable to locate libxml2 when installing gem

However when I try running

gem install twilio-ruby

I recieve an error that it cannot find libxml2.I have tried the following

gem install twilio-ruby -- --with-xml2-dir=/usr/local/Cellar/libxml2

gem install twilio-ruby -- --use-system-libraries


Then all of these three together:

gem install twilio-ruby -- --with-xml2-dir=/usr/local/Cellar/libxml2/2.

how to specify a ruby version in my appspec file for aws codedeploy

I have it specified in my Gemfile, have tried a few ways in the appspecfile

LifecycleEvent - BeforeInstall
Script - scripts/install_dependencies
[stdout]Successfully installed bundler-1.4
[stdout]Done installing documentation for bundler after 5 seconds
[stdout]1 gem installed
[stdout]Updating installed gems
[stdout]Nothing to update
[stderr]ERROR: Error installing sinatra:
[stderr] rack requires Ruby version >= 2.

Yarn error while deploying application on the Google cloud

FROM node:5

RUN apt-get update \
&& apt-get install -y ruby-full rubygems \
&& gem instal sass
RUN npm install -g gulp node-sass yarn
COPY./var/www
WORKDIR /var/www
EXPOSE 3000

CMD npm rebuild node-sass && yarn install && gulp config --prod && gulp compile && gulp prod


I also tried using (node:6) and (node:7) as images but in error the node version remains v5.

Installing fontcustom on centos 7 returns error

When I try to use sudo gem install fontcustom on my cento7 machine I get the error:

ERROR: Error installing fontcustom:
ruby_dep requires Ruby version >= 2.zip -d sfnt2woff && cd sfnt2woff && make && sudo mv sfnt2woff /usr/local/bin/

git clone --recursive https://github.